  <!doctype html>

<html lang="en" class="bni articlePage ">
    <head>
        <meta charset="utf-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
				<title>CULINARY THRILL SEEKING — ‘Tis the ICY Donuts Season - Port Arthur News | Port Arthur News</title><link rel="preload" href="https://www.panews.com/wp-content/themes/2021-portarthur-child/media/img/brand/logo-white-panews.png" as="image" /><link rel="preload" href="https://www.panews.com/wp-content/themes/2021-portarthur-child/media/img/brand/logo-white-mobile-panews.png" as="image" /><link rel="preload" href="https://www.panews.com/wp-content/themes/2021-bni/media/img/Search_icon-black.png" as="image" /><link rel="preload" href="https://www.panews.com/wp-content/uploads/sites/35/2021/06/Icy1.jpg?w=800" as="image" imagesrcset="https://www.panews.com/wp-content/uploads/sites/35/2021/06/Icy1.jpg 800w, https://www.panews.com/wp-content/uploads/sites/35/2021/06/Icy1.jpg?resize=300,169 300w, https://www.panews.com/wp-content/uploads/sites/35/2021/06/Icy1.jpg?resize=768,432 768w, https://www.panews.com/wp-content/uploads/sites/35/2021/06/Icy1.jpg?resize=622,350 622w" imagesizes="(max-width: 800px) 100vw, 800px" />

        <meta name="viewport" content="width=device-width, initial-scale=1">

        
        <link href="https://www.panews.com/wp-content/themes/2021-bni/style.css?1669760927" as="style">

								<link rel="stylesheet" href="https://www.panews.com/wp-content/themes/2021-bni/media/splide/dist/css/splide.min.css?1669684655" />
				<link rel="stylesheet" href="https://www.panews.com/wp-content/themes/2021-bni/media/css/normalize.css?1669684655" />
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.panews.com/wp-content/themes/2021-bni/style.css?1669760927" />

        <script defer="defer" src="https://www.panews.com/wp-content/themes/2021-bni/media/js/vendors/modernizr-2.6.2.min.js?1669684655" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>

				<link rel="Shortcut Icon" type="image/ico" href="https://www.panews.com/wp-content/themes/2021-portarthur-child/media/img/brand/favicon-panews.png">

				
				<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v19.11 - https://yoast.com/wordpress/plugins/seo/ -->
	<link rel="canonical" href="https://www.panews.com/2022/12/05/culinary-thrill-seeking-tis-the-icy-donuts-season/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="CULINARY THRILL SEEKING — ‘Tis the ICY Donuts Season - Port Arthur News" />
	<meta property="og:description" content="The ICY Donuts Groves sign caught my eye and I had to drive in. I love the breakfast eggrolls they bring to Greater Port Arthur Chamber of Commerce events. I’ve already bragged about their food but had never been there in person. Jennifer Chang set me up with &#8220;one of those eggroll things&#8221; people love. Subscribe to [&hellip;]" />
	<meta property="og:url" content="https://www.panews.com/2022/12/05/culinary-thrill-seeking-tis-the-icy-donuts-season/" />
	<meta property="og:site_name" content="Port Arthur News" />
	<meta property="article:published_time" content="2022-12-05T13:58:09+00:00" />
	<meta property="og:image" content="https://www.panews.com/wp-content/uploads/sites/35/2021/06/Icy1.jpg" />
	<meta property="og:image:width" content="800" />
	<meta property="og:image:height" content="450" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="author" content="Darragh Doiron" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Darragh Doiron" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="3 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebPage","@id":"https://www.panews.com/2022/12/05/culinary-thrill-seeking-tis-the-icy-donuts-season/","url":"https://www.panews.com/2022/12/05/culinary-thrill-seeking-tis-the-icy-donuts-season/","name":"CULINARY THRILL SEEKING — ‘Tis the ICY Donuts Season - Port Arthur News","isPartOf":{"@id":"https://www.panews.com/#website"},"primaryImageOfPage":{"@id":"https://www.panews.com/2022/12/05/culinary-thrill-seeking-tis-the-icy-donuts-season/#primaryimage"},"image":{"@id":"https://www.panews.com/2022/12/05/culinary-thrill-seeking-tis-the-icy-donuts-season/#primaryimage"},"thumbnailUrl":"https://www.panews.com/wp-content/uploads/sites/35/2021/06/Icy1.jpg","datePublished":"2022-12-05T13:58:09+00:00","dateModified":"2022-12-05T13:58:09+00:00","author":{"@id":"https://www.panews.com/#/schema/person/cbffd07e5a113253b5ca3da9a8010e8b"},"breadcrumb":{"@id":"https://www.panews.com/2022/12/05/culinary-thrill-seeking-tis-the-icy-donuts-season/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.panews.com/2022/12/05/culinary-thrill-seeking-tis-the-icy-donuts-season/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.panews.com/2022/12/05/culinary-thrill-seeking-tis-the-icy-donuts-season/#primaryimage","url":"https://www.panews.com/wp-content/uploads/sites/35/2021/06/Icy1.jpg","contentUrl":"https://www.panews.com/wp-content/uploads/sites/35/2021/06/Icy1.jpg","width":800,"height":450,"caption":"Icy Donuts owner Jennifer Chang cuts the ribbon to her business in 2021. (Chris Moore/ The News)"},{"@type":"BreadcrumbList","@id":"https://www.panews.com/2022/12/05/culinary-thrill-seeking-tis-the-icy-donuts-season/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.panews.com/"},{"@type":"ListItem","position":2,"name":"CULINARY THRILL SEEKING — ‘Tis the ICY Donuts Season"}]},{"@type":"WebSite","@id":"https://www.panews.com/#website","url":"https://www.panews.com/","name":"Port Arthur News","description":"Connecting Communities","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.panews.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Person","@id":"https://www.panews.com/#/schema/person/cbffd07e5a113253b5ca3da9a8010e8b","name":"Darragh Doiron","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.panews.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/d749ae62483bdddabb33a9876b57b0c4?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/d749ae62483bdddabb33a9876b57b0c4?s=96&d=mm&r=g","caption":"Darragh Doiron"},"url":"https://www.panews.com/author/darragh-doiron/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel="alternate" type="application/rss+xml" title="Port Arthur News &raquo; CULINARY THRILL SEEKING — ‘Tis the ICY Donuts Season Comments Feed" href="https://www.panews.com/2022/12/05/culinary-thrill-seeking-tis-the-icy-donuts-season/feed/" />
<script type="pmdelayedscript" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.panews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.1.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(p&&p.fillText)switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<style id='wp-parsely-recommendations-style-inline-css'>
.parsely-recommendations-list-title{font-size:1.2em}.parsely-recommendations-list{list-style:none;padding:unset}.parsely-recommendations-cardbody{overflow:hidden;padding:.8em;text-overflow:ellipsis;white-space:nowrap}.parsely-recommendations-cardmedia{padding:.8em .8em 0}

</style>
<link rel='stylesheet' id='all-css-2' href='https://www.panews.com/_static/??-eJx9jUkOwjAMRS9E4nYDYoE4S+qYYnAGxY5Qb0+7QKJCYvmHpwev6jij9EgKD4VEkQMJJcq2C1XCQs0JzQEXnzh7VD3AP3zdvvMOwpJt+1TpM+cNtFYymaut3FjIVUbrjSCyGkxS8KlebRHyU2eJv/a1AJSgyujsvhr1I7ymy3g8DcM4no/DG3XpWeg=' type='text/css' media='all' />
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='all-css-4' href='https://www.panews.com/_static/??-eJyNUF1vwyAM/ENzCJW6qQ/TfspEgQZv5kPYqOq/H0nbhyyLtBdk7s53ttW1ACZLzXlWllk5wwFtTjxETENHXtRviXGdgrOpK0nvEZ9EFWoTJp6hkolYLS902a6UMRbywGIuFyDkzrQzoV3SNiTcyf1gdJMXyEWwr6EMs5f74GtmYyDBx77iYTzoPnoVUyW0CjYgOcVyI79piQ2esV9eirHfoPVwVDG7Rt2Lg6neGeduS4lp+rfFZ7+54mzREFCeMq8+f55+z2re/QHMPR/xXb++jaPWp+PpBwSBvQc=' type='text/css' media='all' />
<style id='admin-bar-inline-css'>
#wp-admin-bar-my-sites-search.hide-if-no-js {
	display: none;
}
#wp-admin-bar-my-sites-search label[for="my-sites-search-text"] {
	clip: rect(1px, 1px, 1px, 1px);
	position: absolute !important;
	height: 1px;
	width: 1px;
	overflow: hidden;
}
#wp-admin-bar-my-sites-search {
	height: 38px;
}
#wp-admin-bar-my-sites-search .ab-item {
	height: 34px;
}
#wp-admin-bar-my-sites-search input {
	padding: 0 2px;
	width: 95%;
	width: calc( 100% - 4px );
}
	
</style>
<style id='wp-polls-inline-css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.panews.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<script type="pmdelayedscript" src="https://www.panews.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZebmaeXVayjj0+Rbm5melFiSSpUsX2uraGZuYGBoaGlmUEWAK9AIhc=" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script><script src="https://www.panews.com/wp-content/plugins/trinity-audio/js/the_content-hook-script.js?ver=6.1.1" id="the_content-hook-script-js" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script id="the_content-hook-script-js-after" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
console.debug('TRINITY_WP', 'Skip player from rendering', 'is single: 1, is main loop: , is main query: 1', 'TS: 2022-12-05 16:46:03');
</script>
<link rel="https://api.w.org/" href="https://www.panews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.panews.com/wp-json/wp/v2/posts/136912" /><link rel='shortlink' href='https://www.panews.com/?p=136912' />
<link rel="alternate" type="application/json+oembed" href="https://www.panews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.panews.com%2F2022%2F12%2F05%2Fculinary-thrill-seeking-tis-the-icy-donuts-season%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.panews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.panews.com%2F2022%2F12%2F05%2Fculinary-thrill-seeking-tis-the-icy-donuts-season%2F&#038;format=xml" />
<link href="https://trinitymedia.ai/" rel="preconnect" crossorigin="anonymous" />
<link href="https://vd.trinitymedia.ai/" rel="preconnect" crossorigin="anonymous" />
	<style>img#wpstats{display:none}</style>
		<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-63298050-1', 'auto');
  ga('send', 'pageview');
</script>

      <meta name="onesignal" content="wordpress-plugin"/>
            <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = 'OneSignalSDKUpdaterWorker.js';
                      OneSignal.SERVICE_WORKER_PATH = 'OneSignalSDKWorker.js';
                      OneSignal.SERVICE_WORKER_PARAM = { scope: '/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/push/onesignal/' };
        OneSignal.setDefaultNotificationUrl("https://www.panews.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'd146dd30-15f2-4c9c-94a4-ea62738fa763';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.panews.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.1bb493cc-6f2b-4253-90e1-02d85a4b9e78";
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['actionMessage'] = "Be the first to know! Get notifications on news and updates.";
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
								<script type="text/javascript">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</script>



				<script defer="defer" type="pmdelayedscript" src="https://www.panews.com/wp-content/themes/2021-bni/media/js/colorbox/jquery.colorbox-min.js" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
        <link href="https://www.panews.com/wp-content/themes/2021-bni/media/js/colorbox/colorbox.css" rel="stylesheet">

        <script src="https://www.panews.com/wp-content/themes/2021-bni/media/js/assets/optimera/optiCommon-1.0.0.js" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
        <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
          var optiCommon = optiCommon || {};

          /**
           * Set the Optimera data splitter parameters
           * additionalOptimeraParams can be empty, only the default device type will be included automatically.
           * CustomParams can be set to add a loggedIn parameter to be set later. 
           * */
           optiCommon.init({
           splitters: {
           additionalOptimeraParams: [],
             customParams: ['loggedIn'],
          }
          });
        </script>


                <script type="pmdelayedscript" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://gondolagnome.com/v2/0/hzeDT7NliS7rw7MlQb_eBzUMDFd5OqMV6pUG5rpjWt91xrOnCQWMm5ro-0hkjE7Id2RAf-5Wc33Vcg",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(n,e,r,t){function o(){if((function o(t){try{return(t=localStorage.getItem("v4ac1eiZr0"))&&0<t.split(",")[4]}catch(n){}return!1})()){var t=n[e].pubads();typeof t.setTargeting===r&&t.setTargeting("admiral-engaged","true")}}(t=n[e]=n[e]||{}).cmd=t.cmd||[],typeof t.pubads===r?o():typeof t.cmd.unshift===r?t.cmd.unshift(o):t.cmd.push(o)})(window,"googletag","function");;;;;</script>


        
                  
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
		console.log('%c TESTING OPT V 0.1', 'background: #222; color: red; font-weigit: bold;');
		addEventListener('DOMContentLoaded', (event) => {
			opt_loggedin = loggedin.toString();
			optiCommon.setCustomParam({
				'name': 'loggedIn', // must match the param name set in the init above
				'value': opt_loggedin, // must be a string, not bool
			});
		});

  </script>

  <!-- DFP Work -->
    
        <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>

        <link rel="stylesheet" type="text/css" href="https://htlbid.com/v3/panews.com/htlbid.css" />
    <script src="https://htlbid.com/v3/panews.com/htlbid.js" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
     
<script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
  window.googletag = window.googletag || {cmd: []};
  window.htlbid = window.htlbid || {};
  htlbid.cmd = htlbid.cmd || [];
  htlbid.cmd.push(function() {
          htlbid.setTargeting('is_testing', 'no');
    
      htlbid.setFirstPartyData({
        site: {
          keywords: 'columns, groves, local, news, news-main, opinion, '
        }
      });

  });



googletag.cmd.push(function() {

    			googletag.defineSlot('/1613683/PAN-300x250-instory-third', [[300, 250], [1, 1]], 'div-gpt-ad-instory-third').addService(googletag.pubads());
			FEATUREDGALLERY_AD = googletag.defineSlot('/1613683/PAN-300x250-featured_gallery', [300, 250], 'div-gpt-ad-bigblock-featured_gallery').addService(googletag.pubads());
    
        if (!loggedin) {
			googletag.defineSlot('/1613683/PAN-1x1-wall', [1,1], 'div-gpt-ad-one_by_one_wall').addService(googletag.pubads());
			googletag.defineSlot('/1613683/PAN-1x1-2', [1,1], 'div-gpt-ad-extra_one_by_one').addService(googletag.pubads());
			googletag.defineSlot('/1613683/PAN-1x1-3', [1,1], 'div-gpt-ad-extra_oop').addService(googletag.pubads());
			googletag.defineSlot('/1613683/PAN-1x1-4', [1,1], 'div-gpt-ad-extra_one_by_one_two').addService(googletag.pubads());
  } else {
			googletag.defineSlot('/1613683/PAN-sub-1x1-2', [1,1], 'div-gpt-ad-extra_one_by_one').addService(googletag.pubads());
  }
       

    			googletag.defineSlot('/1613683/PAN-300x250-1', [300, 250], 'div-gpt-ad-bigblock-1').addService(googletag.pubads());
			googletag.defineSlot('/1613683/PAN-300x250-2', [300, 250], 'div-gpt-ad-bigblock-2').addService(googletag.pubads());
			googletag.defineSlot('/1613683/PAN-300x250-3', [300, 250], 'div-gpt-ad-bigblock-3').addService(googletag.pubads());
			googletag.defineSlot('/1613683/PAN-300x250-4', [300, 250], 'div-gpt-ad-bigblock-4').addService(googletag.pubads());
			googletag.defineSlot('/1613683/PAN-300x250-5', [300, 250], 'div-gpt-ad-bigblock-5').addService(googletag.pubads());
			googletag.defineSlot('/1613683/PAN-300x250-12', [300, 250], 'div-gpt-ad-bigblock-12').addService(googletag.pubads());
			googletag.defineSlot('/1613683/PAN-300x250-13', [300, 250], 'div-gpt-ad-bigblock-13').addService(googletag.pubads());
			googletag.defineSlot('/1613683/PAN-300x250-18', [300, 250], 'div-gpt-ad-bigblock-18').addService(googletag.pubads());

			googletag.defineSlot('/1613683/PAN-300x600-1', [[300, 600], [160, 600]], 'div-gpt-ad-halfpage-1').addService(googletag.pubads());

      var large_leaderboard_one = googletag
        .defineSlot('/1613683/PAN-970x250-1', [[970, 90], [970, 250], [728, 90], [320, 50]], 'div-gpt-ad-largeleaderboard-one')
        .addService(googletag.pubads());
          var large_leaderboard_four = googletag
        .defineSlot('/1613683/PAN-970x250-4', [[970, 90], [970, 250], [728, 90], [320, 50]], 'div-gpt-ad-largeleaderboard-four')
        .addService(googletag.pubads());

      var leaderboard_mapping = googletag.sizeMapping()
        .addSize([970, 728], [[970, 250], [970, 90], [728, 90]])
        .addSize([320, 240], [320, 50])
        .addSize([0, 0], [])
        .build();

      large_leaderboard_one.defineSizeMapping(leaderboard_mapping);
          large_leaderboard_four.defineSizeMapping(leaderboard_mapping);

      
      if (!loggedin) {
          googletag.defineOutOfPageSlot('/1613683/PAN-1x1-1', 'div-gpt-ad-screenshift').addService(googletag.pubads());
      } else {
          googletag.defineOutOfPageSlot('/1613683/PAN-sub-1x1-1', 'div-gpt-ad-screenshift').addService(googletag.pubads());
      }

       



                          googletag.pubads().setTargeting("catname", [ "columns", "groves", "local", "news", "news-main", "opinion",  ]);
                        


          googletag.pubads().setTargeting("pageurl", "/2022/12/05/culinary-thrill-seeking-tis-");
    
    
		googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs()
    googletag.pubads().disableInitialLoad();
    googletag.enableServices();

});


</script>


        
                
	                  <script defer="defer" type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
      


          </head>
		<body id="articlePage" class="">
        <!--[if lt IE 7]>
            <p class="chromeframe">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> or <a href="http://www.google.com/chromeframe/?redirect=true">activate Google Chrome Frame</a> to improve your experience.</p>
        <![endif]-->
                
				<div id="" class="undertone">

            <div id="sup_nav" class="sup_nav single">
    <div class="wrapper">
      <div id="logo">
        <a href="https://www.panews.com" class="desktop">
          <img data-perfmatters-preload src="https://www.panews.com/wp-content/themes/2021-portarthur-child/media/img/brand/logo-white-panews.png" alt="Port Arthur News" />
        </a>
        <a href="https://www.panews.com" class="mobile">
          <img data-perfmatters-preload src="https://www.panews.com/wp-content/themes/2021-portarthur-child/media/img/brand/logo-white-mobile-panews.png" alt="Port Arthur News" />
        </a>
      </div>
      <div class="right_items">
        <div class="share_buttons_group">
        <div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-136912" class="share-facebook sd-button share-icon no-text" href="https://www.panews.com/2022/12/05/culinary-thrill-seeking-tis-the-icy-donuts-season/?share=facebook" target="_blank" title="Click to share on Facebook" ><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-136912" class="share-twitter sd-button share-icon no-text" href="https://www.panews.com/2022/12/05/culinary-thrill-seeking-tis-the-icy-donuts-season/?share=twitter" target="_blank" title="Click to share on Twitter" ><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.panews.com/2022/12/05/culinary-thrill-seeking-tis-the-icy-donuts-season/#print" target="_blank" title="Click to print" ><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="mailto:?subject=%5BShared%20Post%5D%20CULINARY%20THRILL%20SEEKING%20%E2%80%94%20%E2%80%98Tis%20the%20ICY%20Donuts%20Season&body=https%3A%2F%2Fwww.panews.com%2F2022%2F12%2F05%2Fculinary-thrill-seeking-tis-the-icy-donuts-season%2F&share=email" target="_blank" title="Click to email a link to a friend" data-email-share-error-title="Do you have email set up?" data-email-share-error-text="If you&#039;re having problems sharing via email, you might not have email set up for your browser. You may need to create a new email yourself." data-email-share-nonce="636a860bee" data-email-share-track-url="https://www.panews.com/2022/12/05/culinary-thrill-seeking-tis-the-icy-donuts-season/?share=email"><span></span><span class="sharing-screen-reader-text">Click to email a link to a friend (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>        </div>
        <div id="right_items_extra">
        <span id="login_link"></span>
<span id="subscribe_button"><a href="/subscriptions/" class="subscribe">Subscribe</a></span>        </div>
      </div>
    </div>
    <nav role="navigation">
      <div class="wrapper">
        <div id="menuToggle">
          <input type="checkbox" />
          <span></span>
          <span></span>
          <span></span>
          
	
        <ul id="menu-main" class="menu"><li id="menu-item-115137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-115137"><a href="https://www.panews.com/">Home</a></li>
<li id="menu-item-115139" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-115139"><a href="https://www.panews.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-115142" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115142"><a href="https://www.panews.com/category/community/">Community</a></li>
	<li id="menu-item-115141" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-115141"><a href="https://www.panews.com/category/opinion/">Opinion</a></li>
</ul>
</li>
<li id="menu-item-115140" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115140"><a href="https://www.panews.com/category/sports/">Sports</a></li>
<li id="menu-item-115143" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115143"><a href="https://www.panews.com/category/obituaries/">Obits</a></li>
<li id="menu-item-115145" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-115145"><a href="https://digital.panews.com/">E-Edition</a></li>
<li id="menu-item-115146" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-115146"><a href="https://marketplace.panews.com/AdHunter/portarthur">Classifieds</a></li>
<li id="menu-item-125664" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-125664"><a href="https://marketplace.panews.com/AdHunter/portarthur/Home/Search?majorClass=2600">Public Notices</a></li>
<li id="menu-item-126073" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-126073"><a href="https://www.panews.com/contests/">Contests</a></li>
<li id="menu-item-115152" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-115152"><a href="https://www.panews.com/submit/">Services</a>
<ul class="sub-menu">
	<li id="menu-item-115150" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115150"><a href="https://www.panews.com/about-us/">About Us</a></li>
	<li id="menu-item-115155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115155"><a href="https://www.panews.com/submit/submit-a-news-tip/">Submit a news tip</a></li>
	<li id="menu-item-115156" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115156"><a href="https://www.panews.com/submit/submit-a-photo/">Submit a photo</a></li>
	<li id="menu-item-115153" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115153"><a href="https://www.panews.com/submit/submit-a-classified-ad/">Submit a Classified Ad</a></li>
	<li id="menu-item-115154" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115154"><a href="https://www.panews.com/submit/submit-a-letter-to-the-editor/">Submit a letter to the editor</a></li>
</ul>
</li>
<li id="menu-item-115157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115157"><a href="https://www.panews.com/special-sections/">Special Sections</a></li>
<li id="menu-item-115554" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115554"><a href="https://www.panews.com/season-of-giving/">Season Of Giving</a></li>
<li class="search_bar"> <form id="search_bar" action="https://www.panews.com/site-search/" class="search_bar_form" method="get" tabindex="0"> <img data-perfmatters-preload src="https://www.panews.com/wp-content/themes/2021-bni/media/img/Search_icon-black.png" width="30" height="30" /> <input type="text" name="q" class="searchQuery" placeholder="Search Port Arthur News..." value="" /> <input type="submit" class="searchButton" value="Go" /> </form> </li></ul>
        </div>
      </div>
    </nav>
  </div>

					<div id="main_body" class="wrapper">
        <!-- SCREENSHIFT -->
<div id='div-gpt-ad-screenshift'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-screenshift');
    });
  </script>
</div> 

						<div id="content" class="flownews">
							<div id="notifications">
																
																							</div>

        <div class="ad mobile_sticky_top">
          <div class="large_leaderboard"><!-- ROS_970x250-1 -->
<div id='div-gpt-ad-largeleaderboard-one'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-largeleaderboard-one');
    });
  </script>
</div></div>
        </div>


  <div class="one_by_one_group">
  <!-- one_by_one_wall-->
<div id='div-gpt-ad-one_by_one_wall'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-one_by_one_wall');
    });
  </script>
</div>  </div>
 

	  <div class="page_type-story">
  
  <div class="main_column">
    <div class="story">
      
      

      <div id="article">


        

        <div class="story_grid">
          <div class="story_detail">

            <div class="one_by_one_group">
              <!-- extra_one_by_one_two -->
<div id='div-gpt-ad-extra_one_by_one_two'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-extra_one_by_one_two');
    });
  </script>
</div>              <!-- extra_oop -->
<div id='div-gpt-ad-extra_oop'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-extra_oop');
    });
  </script>
</div>            </div>
            <div id="story_one_by_one_group" class="one_by_one_group">
              <!-- extra_one_by_one -->
<div id='div-gpt-ad-extra_one_by_one'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-extra_one_by_one');
    });
  </script>
</div>            </div>

            <div id="article_info">

              
              <h2 class="headline">CULINARY THRILL SEEKING — ‘Tis the ICY Donuts Season</h2>

              <p class="pubStamp">Published 7:58 am Monday, December 5, 2022</p>

                            <div class="byline">
                
                <p class="author">
                          <strong>By <a href="https://www.panews.com/author/darragh-doiron/" rel="bookmark">Darragh Doiron</a></strong>

                                  </p>
                                <div class="clearfix"></div>
              </div><!-- END BYLINE -->
                          </div>

              <div class="gallery_group">
      <div id="story_photo_group">
        
                                    <dl class='story_photo_item'><dt><img data-perfmatters-preload width="800" height="450" src="https://www.panews.com/wp-content/uploads/sites/35/2021/06/Icy1.jpg?w=800" class="attachment-large size-large wp-post-image" alt="" decoding="async" srcset="https://www.panews.com/wp-content/uploads/sites/35/2021/06/Icy1.jpg 800w, https://www.panews.com/wp-content/uploads/sites/35/2021/06/Icy1.jpg?resize=300,169 300w, https://www.panews.com/wp-content/uploads/sites/35/2021/06/Icy1.jpg?resize=768,432 768w, https://www.panews.com/wp-content/uploads/sites/35/2021/06/Icy1.jpg?resize=622,350 622w" sizes="(max-width: 800px) 100vw, 800px" /></dt><dd class='wp-caption-text'>Icy Donuts owner Jennifer Chang cuts the ribbon to her business in 2021. (Chris Moore/ The News)</dd></dl>

              </div>
    </div>

            
        <table id="trinity-audio-table" style="width:100%; display: table;">
            <tr>
                <td id="trinity-audio-tab" style="border: none;">
                    <div id="trinity-audio-player-label"></div>
                    <script nitro-exclude data-trinity-mount-date="2022-12-05 16:46:03" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">var TRINITY_TTS_WP_CONFIG = {"cleanText":"CULINARY THRILL SEEKING \u2014 \u2018Tis the ICY Donuts Season. The\u00a0ICY Donuts Groves\u00a0sign caught my eye and I had to drive in.\r\n\r\nI love the breakfast eggrolls they bring to Greater Port Arthur Chamber of Commerce events. I\u2019ve already bragged about their food but had never been there in person.\r\n\r\nJennifer Chang set me up with \"one of those eggroll things\" people love.\r\n\r\n\r\n\r\nThe skin is so delicate and crispy. Then there was the hot, fruity tea they're known for hit. It hit the spot on a windy day.\r\n\r\nShe also coaxed me into a fritter, which is already my favorite.\r\n\r\nI think all those menu offerings have the extra ingredient of \"love\" mixed in there.\r\n\r\nMs. Jennifer's super-friendly face is just one more added bonus.\r\n\r\nGroves foodies, you are so lucky.\r\n\r\nNow consider these holiday mood makers:\r\n\r\nLet\u2019s get Latin \u2013\u00a0Mov\u00e9o is Latin for \u201cto move\u201d and the name of a company that has brought straight-up style to resistance bands. I\u2019m rocking a mermaid pattern and there are artsy florals, peaches and (I couldn\u2019t do it) junk food styles.\r\n\r\nThey just feel good in your hands and you won\u2019t mind popping one out of your bag just so people will ask about it. Style and function on much equipment\/accessories, with an attitude that everyone of every size ought to feel better about getting fit is what you\u2019ll find at\u00a0moveofitco.com.\r\n\r\nThena \u2013\u00a0Turmeric and colloidal oatmeal I get. The arnica in Thena Natural Wellness products threw me. I looked up the daisy-like flower from Europe, used for bruising and found it\u2019s also call wolf\u2019s bane. It\u2019s the stuff fairy tales or made of, but Thena uses very natural stuff to treat eczema and a host of other sink issues.\u00a0Thena.biz connects you to reviews from satisfied users and I\u2019m another from the feel-good foot balm soothing from tea tree, eucalyptus and lemongrass.\r\n\r\nMighty Good\u00a0\u2013 Superior dippability may be provable (and I\u2019d be happy to try) but Zack\u2019s Mighty Organic Tortilla Chips do have a \u201cfirst\u201d claim regarding regenerative agriculture. That\u2019s a combo of conservation and rehabilitation that begins with soil and involves crop rotation, so Zack waited a long time to get these chips right. When I made turkey nachos with Thanksgiving leftovers, I dipped to him. They\u2019re mighty corny, from heirloom stock; mighty sturdy from being a rested tortilla first; and come from mighty land. I was super proud to enjoy the lime and the sea salt versions. Nacho style, I\u2019m coming for you.\u00a0Learn more at zacksmighty.com.\r\n\r\nDevoted to Freshness\u00a0\u2013 At the end of the day it\u2019s a culture and lifestyle, says the creator of\u00a0\u00a0Devoci\u00f3n\u00a0coffee. At the beginning of the day it\u2019s fresh beans from Columbia to your door in as little as 10 days. They haven\u2019t been sitting around for months in a warehouse. I\u2019ll spend extra morning moments grinding this batch until my bag is empty. It\u2019s a time of awareness and gratitude that\u2019s worth it. I\u2019m savoring Holiday Blend with notes of mulled wine, blueberry and dark chocolate.\u00a0Devocion.com shares the beany journey.\r\n\r\nPlant puff\u00a0\u2013 Have you ever touched a soft, cool petal to your skin?\u00a0The Japanese Organic Konjac Face sponge puff is like that, because it\u2019s from extracts of konjac plants of Yamamoto Farms in Japan. Full of minerals and antioxidants, it cleanses and exfoliates in the freshest way. They\u2019ve been doing this for a hundred years because it works. Something different, once activated with water, keep it in a lidded container in the fridge.\u00a0Learn more at RisingSunBrands.com.\r\n\r\nDarragh Doiron is a Port Arthur area foodie happy to sample all the flavors of the holidays this season. Converse with her via\u00a0darraghcastillo@icloud.com.","pluginVersion":"5.3.4"};</script><div class='trinityAudioPlaceholder' data-trinity-mount-date='2022-12-05 16:46:03'></div>
                </td>
            </tr>
        </table><p>The ICY Donuts Groves sign caught my eye and I had to drive in.</p>
<p>I love the breakfast eggrolls they bring to Greater Port Arthur Chamber of Commerce events. I’ve already bragged about their food but had never been there in person.</p>
<p>Jennifer Chang set me up with &#8220;one of those eggroll things&#8221; people love.</p>
<div id="attachment_136913" style="width: 632px" class="wp-caption alignnone"><a href="https://www.panews.com/wp-content/uploads/sites/35/2022/12/CTS-ICY-Donuts-Groves.jpg"><img aria-describedby="caption-attachment-136913" decoding="async" loading="lazy" class="size-full wp-image-136913" src="https://www.panews.com/wp-content/uploads/sites/35/2022/12/CTS-ICY-Donuts-Groves.jpg" alt="" width="622" height="352" srcset="https://www.panews.com/wp-content/uploads/sites/35/2022/12/CTS-ICY-Donuts-Groves.jpg 622w, https://www.panews.com/wp-content/uploads/sites/35/2022/12/CTS-ICY-Donuts-Groves.jpg?resize=300,170 300w, https://www.panews.com/wp-content/uploads/sites/35/2022/12/CTS-ICY-Donuts-Groves.jpg?resize=618,350 618w" sizes="(max-width: 622px) 100vw, 622px" /></a><p id="caption-attachment-136913" class="wp-caption-text">Jennifer Chang fills ICY Donuts Groves window with smiles and extra special flavors. (Darragh Doiron/Special to The News)</p></div>
<div class="ad count17"><div id='div-gpt-ad-bigblock-1'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-1');
    });
  </script>
</div></div><div class="instory_widget"><div class="textwidget custom-html-widget"><!-- Begin Mailchimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://panews.us18.list-manage.com/subscribe/post?u=e0ab158a9f342dd4350131eae&amp;id=992d335dd8" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	<h2 for="mce-EMAIL">Subscribe to our free email newsletter</h2>
			<p for="mce-EMAIL">Get the latest news sent to your inbox</p>
	<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_e0ab158a9f342dd4350131eae_992d335dd8" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>

<!--End mc_embed_signup--></div></div><p>The skin is so delicate and crispy. Then there was the hot, fruity tea they&#8217;re known for hit. It hit the spot on a windy day.</p>
<p>She also coaxed me into a fritter, which is already my favorite.</p>
<p>I think all those menu offerings have the extra ingredient of &#8220;love&#8221; mixed in there.</p>
<div class="ad"><div id='div-gpt-ad-bigblock-2'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-2');
    });
  </script>
</div></div><div class="ad"><div id='div-gpt-ad-bigblock-instory-third'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-instory-third');
    });
  </script>
</div></div><p>Ms. Jennifer&#8217;s super-friendly face is just one more added bonus.</p>
<p>Groves foodies, you are so lucky.</p>
<p>Now consider these holiday mood makers:</p>
<div id="cedato-unit"></div><div class="ad"><div id='div-gpt-ad-bigblock-3'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-3');
    });
  </script>
</div></div><p><strong>Let’s get Latin – </strong>Movéo is Latin for “to move” and the name of a company that has brought straight-up style to resistance bands. I’m rocking a mermaid pattern and there are artsy florals, peaches and (I couldn’t do it) junk food styles.</p>
<p>They just feel good in your hands and you won’t mind popping one out of your bag just so people will ask about it. Style and function on much equipment/accessories, with an attitude that everyone of every size ought to feel better about getting fit is what you’ll find at <a href="http://www.moveofitco.com/">moveofitco.com</a>.</p>
<p><strong>Thena – </strong>Turmeric and colloidal oatmeal I get. The arnica in Thena Natural Wellness products threw me. I looked up the daisy-like flower from Europe, used for bruising and found it’s also call wolf’s bane. It’s the stuff fairy tales or made of, but Thena uses very natural stuff to treat eczema and a host of other sink issues. <a href="http://www.thenabiz.com/">Thena.biz</a> connects you to reviews from satisfied users and I’m another from the feel-good foot balm soothing from tea tree, eucalyptus and lemongrass.</p>
<p><strong>Mighty Good –</strong> Superior dippability may be provable (and I’d be happy to try) but Zack’s Mighty Organic Tortilla Chips do have a “first” claim regarding regenerative agriculture. That’s a combo of conservation and rehabilitation that begins with soil and involves crop rotation, so Zack waited a long time to get these chips right. When I made turkey nachos with Thanksgiving leftovers, I dipped to him. They’re mighty corny, from heirloom stock; mighty sturdy from being a rested tortilla first; and come from mighty land. I was super proud to enjoy the lime and the sea salt versions. Nacho style, I’m coming for you. <a href="http://www.zacksmighty.com/">Learn more at zacksmighty.com</a>.</p>
<p><strong>Devoted to Freshness –</strong> At the end of the day it’s a culture and lifestyle, says the creator of  Devoción coffee. At the beginning of the day it’s fresh beans from Columbia to your door in as little as 10 days. They haven’t been sitting around for months in a warehouse. I’ll spend extra morning moments grinding this batch until my bag is empty. It’s a time of awareness and gratitude that’s worth it. I’m savoring Holiday Blend with notes of mulled wine, blueberry and dark chocolate. <a href="http://www.devocion.com/">Devocion.com</a> shares the beany journey.</p>
<p><strong>Plant puff –</strong> Have you ever touched a soft, cool petal to your skin? The Japanese Organic Konjac Face sponge puff is like that, because it’s from extracts of konjac plants of Yamamoto Farms in Japan. Full of minerals and antioxidants, it cleanses and exfoliates in the freshest way. They’ve been doing this for a hundred years because it works. Something different, once activated with water, keep it in a lidded container in the fridge. Learn more at <a href="https://4j8sf.r.ag.d.sendibm3.com/mk/cl/f/SwAt4lOC5SXBXnEO5wlsis1t5RyEU_0tM5oBWfNgG1XxF4mz4lEGZyDw7fbmqoGC4X0nMyN9b4zX1Cz3cilGv97L5rpGy85BfKAfrh0CUZIDHB7bhMFk5k7A2T1MCrW3hpAolSQnnMy1pUpkz0cpjAvJPOjvIvx7t4Ynx3K0tARFSphiQUQg10SmozsZqGMn2RJGlIdVLqT4oOb1l87caUYWYZt-2ODz-2CYCl5NU-rLmDBIqq_a5hxlWnXZv9rV">RisingSunBrands.com</a>.</p>
<p><em>Darragh Doiron is a Port Arthur area foodie happy to sample all the flavors of the holidays this season. Converse with her via <a href="mailto:darraghcastillo@icloud.com">darraghcastillo@icloud.com</a>.</em></p>

            <div id="comments"> </div><!-- END comments -->
            
                                  


              <div id="NTV_1"></div>

                      
<div class="more_to_explore">
  <h4>More Groves</h4>
  
        <div class="story">
                    <a href="https://www.panews.com/2022/12/04/port-neches-groves-knows-time-location-of-next-opponent-local-fans-ready-to-travel/?utm_source=site&utm_medium=organic&utm_campaign=recirculation" class="teasePhoto" rel="bookmark">
            <img width="400" height="220" src="https://www.panews.com/wp-content/uploads/sites/35/2022/12/IMG_37021-web.jpg?w=400&amp;h=220&amp;crop=1" class="attachment-category-medium size-category-medium wp-post-image" alt="" decoding="async" loading="lazy" />          </a>
                    <h3><a href="https://www.panews.com/2022/12/04/port-neches-groves-knows-time-location-of-next-opponent-local-fans-ready-to-travel/?utm_source=site&utm_medium=organic&utm_campaign=recirculation" rel="bookmark" title="Port Neches-Groves knows time, location of next opponent. Local fans ready to travel.">Port Neches-Groves knows time, location of next opponent. Local fans ready to travel.</a></h3>

          <div class="clearfix"></div>
        </div>

        
        <div class="story">
                    <a href="https://www.panews.com/2022/12/02/groves-leaders-plan-to-review-sale-of-building-waste-water-plant-upgrades/?utm_source=site&utm_medium=organic&utm_campaign=recirculation" class="teasePhoto" rel="bookmark">
            <img width="400" height="220" src="https://www.panews.com/wp-content/uploads/sites/35/2020/09/Sosa-4.jpg?w=400&amp;h=220&amp;crop=1" class="attachment-category-medium size-category-medium wp-post-image" alt="" decoding="async" loading="lazy" />          </a>
                    <h3><a href="https://www.panews.com/2022/12/02/groves-leaders-plan-to-review-sale-of-building-waste-water-plant-upgrades/?utm_source=site&utm_medium=organic&utm_campaign=recirculation" rel="bookmark" title="Groves leaders plan to review sale of building, waste water plant upgrades">Groves leaders plan to review sale of building, waste water plant upgrades</a></h3>

          <div class="clearfix"></div>
        </div>

        
        <div class="story">
                    <a href="https://www.panews.com/2022/12/02/indians-coach-jeff-joseph-shares-thoughts-following-wild-night-against-fort-bend-marshall/?utm_source=site&utm_medium=organic&utm_campaign=recirculation" class="teasePhoto" rel="bookmark">
            <img width="400" height="220" src="https://www.panews.com/wp-content/uploads/sites/35/2022/12/PNG10-web.jpg?w=400&amp;h=220&amp;crop=1" class="attachment-category-medium size-category-medium wp-post-image" alt="" decoding="async" loading="lazy" />          </a>
                    <h3><a href="https://www.panews.com/2022/12/02/indians-coach-jeff-joseph-shares-thoughts-following-wild-night-against-fort-bend-marshall/?utm_source=site&utm_medium=organic&utm_campaign=recirculation" rel="bookmark" title="Indians coach Jeff Joseph shares thoughts following wild night against Fort Bend Marshall">Indians coach Jeff Joseph shares thoughts following wild night against Fort Bend Marshall</a></h3>

          <div class="clearfix"></div>
        </div>

        
        <div class="story">
                    <a href="https://www.panews.com/2022/12/02/port-neches-groves-plays-thriller-against-fort-bend-marshall-in-quarterfinal-showdown/?utm_source=site&utm_medium=organic&utm_campaign=recirculation" class="teasePhoto" rel="bookmark">
            <img width="400" height="220" src="https://www.panews.com/wp-content/uploads/sites/35/2022/12/PNG4-web.jpg?w=400&amp;h=220&amp;crop=1" class="attachment-category-medium size-category-medium wp-post-image" alt="" decoding="async" loading="lazy" />          </a>
                    <h3><a href="https://www.panews.com/2022/12/02/port-neches-groves-plays-thriller-against-fort-bend-marshall-in-quarterfinal-showdown/?utm_source=site&utm_medium=organic&utm_campaign=recirculation" rel="bookmark" title="Port Neches-Groves plays thriller against Fort Bend Marshall in quarterfinal showdown">Port Neches-Groves plays thriller against Fort Bend Marshall in quarterfinal showdown</a></h3>

          <div class="clearfix"></div>
        </div>

        
</div>
          
            
            
											<div class="print_this bubble_buttons">
													<a href="#">Print Article</a>
											</div><!-- END print_this -->


            <div class="articleOptions bubble_buttons">
              <div class="admin">
</div>
<div class="clearfix"></div>


            </div>

                        
              

<div class="rev_ad">
  <div id="rc-widget-61eef3" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="134171"></div>
    <script type="pmdelayedscript" src="https://assets.revcontent.com/master/delivery.js" defer="defer" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
</div>
  

	
<div class="one_by_one_group">
<div id="rev_video"></div>
</div>



            
            </div><!-- END STORY_DETAIL -->

            <div class="sidebar">
                  
<ul class="sidebar">
	<li>
		<div class="ad ">
			<div id='div-gpt-ad-bigblock-12'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-12');
    });
  </script>
</div>		</div>
	</li>
			<li>
		<div class="ad">
			<div id='div-gpt-ad-bigblock-13'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-13');
    });
  </script>
</div>		</div>
	</li>
		<li>
		<div class="story_list widget">
			<ul>
							</ul>
		</div>
	</li>
		<li>
		<div class="ad">
			<div id='div-gpt-ad-bigblock-18'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-18');
    });
  </script>
</div>		</div>
	</li>
	  </ul>
    <div class="sticky">
      <div class="ad">
        <div id='div-gpt-ad-halfpage-1'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-halfpage-1');
    });
  </script>
</div>      </div>
    </div>            </div>
            <div class="right_rule"></div>
        </div>

    </div>
  </div>

</div>

  

	<div class="clearfix"></div>
    <div id="mobile_sticky_bottom_group" class="ad mobile_sticky_bottom">
      <div class="large_leaderboard"><!-- ROS_970x250-4 -->
<div id='div-gpt-ad-largeleaderboard-four'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-largeleaderboard-four');
    });
  </script>
</div></div>
    </div>
					</div>
					<div id="footer" class="clearfix">
            <div class="wrapper">
              <div id="footSections" class="col">
	                <h4>Sections</h4>
                <ul id="menu-footer-sections" class="menu"><li id="menu-item-115158" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-115158"><a href="https://www.panews.com/">Home</a></li>
<li id="menu-item-115159" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-115159"><a href="https://www.panews.com/category/news/">News</a></li>
<li id="menu-item-115160" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115160"><a href="https://www.panews.com/category/sports/">Sports</a></li>
<li id="menu-item-115161" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-115161"><a href="https://www.panews.com/category/opinion/">Opinion</a></li>
<li id="menu-item-115162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115162"><a href="https://www.panews.com/category/lifestyle/">Lifestyle</a></li>
<li id="menu-item-115163" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-115163"><a href="https://marketplace.panews.com/AdHunter/portarthur">Classifieds</a></li>
<li id="menu-item-115164" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-115164"><a href="https://smb.panews.com/">Small Business</a></li>
</ul>              </div>


              <div id="footServices" class="col">
	                <h4>Services</h4>
                <ul id="menu-footer-services" class="menu"><li id="menu-item-115165" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115165"><a href="https://www.panews.com/about-us/">About Us</a></li>
<li id="menu-item-115166" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115166"><a href="https://www.panews.com/policies/">Policies</a></li>
<li id="menu-item-115167" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115167"><a href="https://www.panews.com/submit/submit-a-news-tip/">Submit a news tip</a></li>
<li id="menu-item-115168" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115168"><a href="https://www.panews.com/submit/submit-a-photo/">Submit a photo</a></li>
</ul>              </div>


              <div id="footCopyright" class="col">
                                <h4>Copyright</h4>
                <ul>
                  <li>&copy; 2022, Port Arthur News</li>
                </ul>

              </div>
            </div>

					</div>
				</div>


				        <script defer="defer" src="https://www.panews.com/wp-content/themes/2021-bni/media/splide/dist/js/splide.min.js?1669684655" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
        <script defer="defer" src="https://www.panews.com/wp-content/themes/2021-bni/media/js/vendors/jquery.contentcarousel.js?1669684655" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
        <script defer="defer" src="https://www.panews.com/wp-content/themes/2021-bni/media/js/vendors/jquery.easing.1.3.js" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
				<script defer="defer" src="https://www.panews.com/wp-content/themes/2021-bni/media/js/vendors/jquery.timeago.js" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
        <script defer="defer" src="https://www.panews.com/wp-content/themes/2021-bni/media/js/plugins.js?1669684655" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
        <script defer="defer" src="https://www.panews.com/wp-content/themes/2021-bni/media/js/main.js?1669684655" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>

        
				
<script type="pmdelayedscript" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">tb_pathToImage = "https://www.panews.com/wp-includes/js/thickbox/loadingAnimation.gif";tb_closeImage = "https://www.panews.com/wp-includes/js/thickbox/tb-close.png";</script>

	<script type="pmdelayedscript" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
		window.WPCOM_sharing_counts = {"https:\/\/www.panews.com\/2022\/12\/05\/culinary-thrill-seeking-tis-the-icy-donuts-season\/":136912};
	</script>
				<script type="pmdelayedscript" src="https://www.panews.com/_static/??/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js,/wp-includes/js/hoverintent-js.min.js?m=1670011960j" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script><script src="https://www.panews.com/wp-includes/js/admin-bar.min.js?ver=6.1.1" id="admin-bar-js" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script id="admin-bar-js-after" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
jQuery(document).ready( function($) {
	$('#wp-admin-bar-my-sites-search.hide-if-no-js').show();
	$('#wp-admin-bar-my-sites-search input').keyup( function( ) {
		var searchValRegex = new RegExp( $(this).val(), 'i');
		$('#wp-admin-bar-my-sites-list > li.menupop').hide().filter(function() {
			return searchValRegex.test( $(this).find('> a').text() );
		}).show();
	});
});
</script>
<script id="wp-polls-js-extra" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
var pollsL10n = {"ajax_url":"https:\/\/www.panews.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
</script>
<script type="pmdelayedscript" src="https://www.panews.com/wp-content/plugins/wp-polls/polls-js.js?m=1669684655g" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script><script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=6.1.1" async="async" id="remote_sdk-js" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script nitro-exclude data-wpfc-render="false" data-trinity-mount-date="2022-12-05 16:46:03" src="https://trinitymedia.ai/player/trinity/4c3d42c678bebf8962f18c548579cf30/?postHash=822964ca417228dec1227958e6c71a0e&#038;language=en-US&#038;voiceGender=m&#038;pageURL=https%3A%2F%2Fwww.panews.com%2F2022%2F12%2F05%2Fculinary-thrill-seeking-tis-the-icy-donuts-season%2F&#038;postConfig&#038;ver=6.1.1" id="trinity-player-js" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script id="sharing-js-js-extra" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script src="https://www.panews.com/wp-content/mu-plugins/jetpack-11.5/_inc/build/sharedaddy/sharing.min.js?ver=11.5.1" id="sharing-js-js" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script id="sharing-js-js-after" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
</script>
	<script src="https://stats.wp.com/e-202249.js" defer type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
	<script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
		_stq = window._stq || [];
		_stq.push([ 'view', {v:'ext',blog:'175119104',post:'136912',tz:'-6',srv:'www.panews.com',hp:'vip',j:'1:11.5.1'} ]);
		_stq.push([ 'clickTrackerInit', '175119104', '136912' ]);
	</script>				</div><!-- END undertone -->
        				<script defer="defer" id="dsq-count-scr" src="//portarthurnews.disqus.com/count.js" async type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
        
                <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
document.addEventListener("DOMContentLoaded", function() {
  htlbid.cmd.push(() => {
    htlbid.refresh();
  });  
});
</script>
        
    <script type="text/javascript" id="perfmatters-delayed-scripts-js">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</script></body>
</html>